This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Fritzing 0.7.7 - can't properly connect parts to the breadboard

pastoreerrante 5 years, 12 months ago

Hi guys,

I'm trying 0.7.7 on Ubuntu 12.04 32 bit. The big problem is that I'm not able to properly connect various parts (resistors, leds and IC for istance) on the breadboard.

With 0.6.3 this connection works great and, in fact, when I put a part onto the breadboard its pins become blue along with the nearest breadboard holes. Once hooked the parts on the breadboard, green lines show the electrical connection path. This behavious is not present on 0.7.7.

When the part is near to the breadboard holes, its pins don't become blue anymore and the part is not hooked properly in them; finally the green electrical paths are absent.

Is there a workaround?

Thank you in advance,

Daniele

Jonathan Cohen 5 years, 12 months ago

Hi Daniele,

This sounds very messed up--I just checked under Linux 10.04, and the breadboard highlighting works properly. Was this a downloaded version, or did you build it yourself? If the former, I would consider clearing your cache and downloading again; make sure you are downloading the 32-bit (or 64-bit) release as appropriate, and that you are launching Fritzing from the "Fritzing" script found at the top level of the installation folder.

HTH,

- j

 

pastoreerrante 5 years, 12 months ago

Hi Jonathan,

it was a fresh downloaded version. The 32 bit version still doesn't work properly here.

Tried the 64 bit (always ubuntu 12.04) all works fine.

Maybe it's worth to know that my 32 bit ubuntu is virtualized. By the way the 0.6.3 on the 32 bit vrtualized ubuntu was installed through apt-get.

Finally I tried to download the tar.bz2 archive again, with no luck.

Regards

MaBerY 5 years, 11 months ago

I also found out and i reported it in another thread

It seems that the breadboard itself is slightly off grid placed when creating a new project

When the breadboard is properly alingned to the 0,1" grid the components places correctly

Strange little bug.

lwxb 3 years, 5 months ago

Thanks!  This issue still shows up in version 0.9.1 and moving the breadboard to align with the grid works like a charm.