This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

MacOS 0.7.11b error message at startup and when adding new parts

Oripy 5 years, 7 months ago

I just downloaded and installed Fritzing for the first time on my Mac (OSX Lion) and I got an error message at startup saying some parts (4) are not found.

I get the same error message when I try to import Adafruit parts.

As this release has been out for quite some time, I wonder if it is a general problem or just my current installation. I just copied the folder from the disc image to my Application folder and run Fritzing.app.

What did I do wrong ?

Thanks

Jonathan Cohen 5 years, 7 months ago

Hi Oripy,

I think we would have heard complaints by now. It should list which parts are missing--if you post these I can make a better guess about what's going wrong.

- j

Oripy 5 years, 7 months ago

I re-downloaded and made a new copy of the folder, same thing.

Note that the folder parts/core/ is empty...

Here is the full error message: p, li { white-space: pre-wrap;

Unable to find the following 4 part(s):

'generic_shrouded_pin_header_10_100mil'

at

'parts/core/generic_shrouded_pin_header_10_100mil.fzp'

'generic_female_pin_header_2_100mil'

at

'parts/core/generic_female_pin_header_2_100mil.fzp'

'mystery_part_sip_3_100mil'

at

'parts/core/mystery_part_3.fzp'

'generic_ic_dip_8_300mil'

at

'parts/core/generic_ic_dip_8_300mil.fzp'

Jonathan Cohen 5 years, 7 months ago

Hi Oripy,

Thanks for the reply.

There is definitely something odd going on. After you copy the files from the dmg to your application folder, in your application folder you should see the following subfolder structure:

fritzing (just a folder)
  bins
  fritzing (the app bundle)
  help
  parts    
    parts.db
  pdb
  sketches
  translations

Is that what you see?

Another couple of questions:

  • When you downloaded the second time, did you clear your browser cache first? otherwise the browser may just have reused the original download, and if that was defective, the second download may not have fixed anything
  • Are you launching Fritzing with a double-click on the app bundle or in some other way?
  • Once Fritzing comes up, can you take a screen shot and email it to info .at. fritzing .dot. org. Maybe a visual will help to further diagnose the problem.

- j

Oripy 5 years, 7 months ago

Yes, the folder structure is exactly like that.

I cleared the cache history.

I tried to launch Fritzing using a double clic on the .app but also by launching it with the console (Applications/fritzing/Fritzing.app/Contents/MacOS/Fritzing) to see if I got some output to help debugging.

I will send the screenshot in a few.

MDanihy 5 years, 6 months ago

I am also getting the same exact errors.  Mountin Lion.  Do not have the folder structure you referenced.  Just the Fritzing bundle app in Applications.

Jonathan Cohen 5 years, 6 months ago

Hi MDanihy,

Are you running version 0.7.11 or 0.7.12?  In 0.7.12, the folder structure is the same, but it is inside the app bundle, rather than external to it.

I am not sure this issue was resolved. I had two ideas, but I don't know whether either of them worked:

-- move Fritzing out of the Applications folder 

-- If this were a Linux machine, I would say it sounds like a permissions problem: Fritzing is having trouble reading and writing files--particularly to .../.config/Fritzing.  I am assuming that your user account has ownership privileges, but you might check that just in case.  I suppose there is a tiny chance it's just that the hard drive is full...

Let me know whether that helps.

Thanks.

- j