This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

How can i fix 'module id'?

Christian Aschoff 7 years, 11 months ago

When i open my sketch, this message shows up:

 

Bauteil '' bei '/Users/caschoff/.config/Fritzing/parts/user/Really_Bare_Bones_Board__a526c3138535d293049833250fd0babe.fzp' hat keine eindeutige module id '9831a538a0dc119fc2096783d47cb9b3'.

Jonathan Cohen 7 years, 11 months ago

Hi Caschoff,

Sorry, no spare time to try to write in German today.

This means you have two copies of the same part.  How that happened is not clear--it could be a Fritzing bug, or it could be simply that you copied an fzp file when making a new part, or perhaps imported a part that you already have.  

What I would do first is temporarily move the fzp file mentioned in the error message to some other folder outside the Fritzing world--like maybe the desktop.  Now run Fritzing.  The message should be gone, but the Really Bare Bones Board should still be available.  If so, then you're done and you can just delete the fzp file.

If you still get the error message when you restart Fritzing, then either you have still another copy of the part--in which case also move that file--or Fritzing found the fzp file in the temporary location, so move it elsewhere.

If the Really Bare Bones part is missing (you can try searching for it using the search input field at the bottom of the Parts Bin), then try the following.  Open up the fzp file with a text editor.  In the first or second line of the file you will see "... moduleId='9831a538a0dc119fc2096783d47cb9b3' ... ".  Stick an 'x' at the end of the moduleId (just after the 3, before the quote), save the file, and return it to its original location.  Then restart Fritzing.

HTH,

- j

 

 

 

 

Christian Aschoff 7 years, 11 months ago

Hi Jonathan,

 

reading english is no problem for me, writing is harder...

 

I think the problem showd up, beause i was in the part editor, changed the RBBB and the save button was disabled. So i just closed the part editor with the red glass button (i'm using a mac). While the save button was disabled, the part editor asked me anyway if i want to save the changes to the part, and i sayed yes.

 

By the way, the holes in the example files for the pcb layout seems to be smaller than the holes in the core library, my RBBB had small holes (i tried to fix that, so the above mentioned happend).

 

And another thing: the crosses for the anchor points are drawn black on the black lines of the part. It would be easier if the were drawn in xor mode...

 

Regards,

Christian

 

Jonathan Cohen 7 years, 11 months ago

Hi Christian,

Save is disabled when it's a core part, but "Save As" should still be available, and that would generate a new module ID.  It's a bug that you were given the save option rather than 'save as' when you closed the parts editor with the close box.

I think I'm not quite following the holes business.  

You're right about the anchor points.

- j