This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Raspbian - upgrading from 0.63 -> 0.9.0b

schlumpf 4 years, 9 months ago

So today I wanted to try Fritzing on a Raspberry Pi and it kept segfaulting - the current package is 0.63.

 

Preparations

So I tried building a new package from the main tree which has 0.9.0b.

I downloaded 3 files listed at https://packages.debian.org/de/sid/fritzing :

  • http://ftp.de.debian.org/debian/pool/main/f/fritzing/fritzing_0.9.0b+dfsg-1.dsc
  • http://ftp.de.debian.org/debian/pool/main/f/fritzing/fritzing_0.9.0b+dfsg.orig.tar.bz2
  • http://ftp.de.debian.org/debian/pool/main/f/fritzing/fritzing_0.9.0b+dfsg-1.debian.tar.xz
apt-get build-dep fritzing
installs the dependancies for the old fritzing - hope all is intalled.

apt-get install libqt4-sql-sqlite
The old package misses a dependancy for the sqlite plugin.

Building

dpkg-source -x fritzing_0.9.0b+dfsg-1.dsc
creates files to built a binary package
change into the created directory "fritzing-0.9.0b+dfsg" and start compiling with "fakeroot debian/rules"

I hope this is complete and helps some1 working on a RPi. I would like to change the formatting, but after setting "Preformatted" I am unable to switch back to "paragraph"-mode.

schlumpf 4 years, 9 months ago

Preparations

apt-get install libboost libboost-dev sqlite3

 

P.S.: need to find out how to edit old posts