This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Error in circuit layout of Arduino Uno (Rev3) - ICSP: right ICSP pins are not at crrect place!

Holger Wirtz 3 years, 6 months ago

Hi all,

 

Damn! I used the element "Arduino Uno (Rev3)" as variant "Arduino Uno (Rev3) - ICSP" as base for my shield (see http://fritzing.org/projects/dmxlight/). While assembling my ordered circuit board I noticed that the used ICSP header on the right has not the exact position (about 3mm shifted to north)!

 

First I thaught that it was my fault because I created a variant with "disconnected" ICSP2 pins, so that the autorouter doen't use them anymore. But after checking my current installation of Version 0.9.1 I saw that the shifted ICSP header is also on the base element!

 

That's really bad - I can throw my three cicuit boards into trash :-(

 

I will try to fix the layout - but I have no idea how to do this. So my questions are:

  1. Do you have the same problem?
  2. Is there already a fix (I found none)?
  3. Cause I'm a newbie to Fritzing: what have I to do for fixing this? Which tools do I need?

Thanks, Holger

Fabian Althaus 3 years, 6 months ago

hello Holger, 

 

from my point of view, you changed the core-svg of the uno(icsp) so that the core-part is broken too. i myself, checked the versions of the board in the downloadable 0.9.1b and the position is correct. 

 

i'm really sorry for your "disaster" and i will integreate a "icsp 1 only" variant to the core-parts.

 

if you want to know how to make working parts, i can would point to the fritzing-sparkfun tutorial. it shows really well what you have to do and what is important for a working part.

 

greetings and sorry for any inconveniece. 

f

Holger Wirtz 3 years, 6 months ago

Ooooohnoooooo - as I wrote in my email: I am such an idiot! I checked the wrong ICSP header against the original Leonardo footprint with ICSP without knowing that they use the same footprint and thaught this maybe a bug in the original one! Don't ask me how I crashed the original layout - I don't know.

 

Thanks a lot for your patience. I will give my circuit another try - hopefully I haven't done anything wrong anymore.

 

Holger

 

cgr 3 years, 6 months ago

Hi Holger, in case it may help you mentally--you are not alone--I misplaced an ICSP also by hand and had to go again. The lack is that in many layouts the ICSP is missing so more error sources are existing. Be also aware that you have the richt diameter in the THT parts! In my first "hand made" ICSP header I have chosen a "small" footprint so not all pin header sizes are compatible.