This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Install and run Fritzing on the Raspberry Pi

nickoppen 4 years, 7 months ago

There are no ready-made versions available for the ARM architecture so there are a few steps you need to take to get Fritzing running on the Pi.

This is the procedure I used for Fritzing 0.7.11b, Qt verison 4.8.2 and boost version 1.49 on the Debian Wheezy platform.

First you need to download some stuff.

Using the Aptitude Package Manager:

 - Under Installed Packages>devel>main mark everything to be upgraded

 - Search for qt and install the latest qt libraries and the qtcreator package

 - Search for and install libboost-all-dev to install version 1.49 of the boost library (it seems to work)

 - Search for and install subversion

 

Downloading these will take quite a while. It does not matter in which order you do them.

Now download the Fritzing source:

 - Copy the svn command from: http://code.google.com/p/fritzing/source/checkout to get the latest source code and run it in an LXTerminal window.

 

Start up Qt Creator from the Programming section in the start menu and load the project called: phoenix.pro in the Fritzing folder. 

The project will not be correctly configured. To configure it go to Tools | Options and select Build and Run.

 - On the General tab select the highest level Fritzing folder. (that was /Fritzing-read-only for me)

 - On the Qt Versions tab Add the following:

- /usr/bin/qmake

- /usr/bin/qmake-qt4 (you probably only need this one)

- /usr/bin/X11/qmake-qt4

 - On the Tool chains tab click Add>GCC and add the path /usr/bin/gcc

 - On the Unconfigured Project tab you should now have the option to select one of your Qt Versions (e.g. Qt 4.8.2 in PATH (System)) and your GCC tool chain.

 - On the CMake tab Browse to the path /usr/bin/qmake-qt4 if it is not there.

 

Now... on the Build menu choose Build All.

 

All going well, about 3 hours later you will have about 21 benign warnings, no critical errors and a new entry in the Programming start menu.

 

Run it and cross your fingers.

 

If you see no error messages and a whole bunch of parts come up on the right hand panel and a bread board on the left hand main window then go insane and make some electonic magic.

If you get a dialog saying:

Parts folder not found followed by one saying

Cannot read file /core.fzb/No such file or directory followed by

Fritzing cannot load the parts bin then you need to tell Fritzing where to find it's data files. In an LXTerminal window execute Fritzing -f <your fritzing folder>. This is what I need to do for now. I'll post a message when I've worked out how to run Fritzing from the start menu with the -f switch.

 

Good luck.


Jonathan Cohen 4 years, 7 months ago

Hi Nick,

Very cool! Thanks for posting this.

- j

mifga 4 years, 7 months ago

Just out of curiosity, what happens when you use "sudo apt-get install fritzing" -- the app loads and you can wire things up. Is the fact that it isn't compiled for ARM mainly an issue because it is too slow or because it really won't work for a lot of things (that I don't notice when first navigating around in the program!)

Heinervdm 4 years, 7 months ago

Hi nickoppen,
why don't you just do:

--

qmake

make

make install

--

in a Terminal, but do these strange things in qt-creator?

Regards
Heiner

nickoppen 4 years, 6 months ago

Hi,

mifga, The package manager only has 0.6.3 and the source got me 0.7.11b. Even after compiling it locally it was still slow. I've since upgraded to a Class4 SDHC card (from a Class 2) but things still run really slowly.

Heinervdm, I'm not really a command line sort of guy. I wanted an IDE anyway for the apps I have planned so I was trying that out at the same time.

To be perfectly honest, I also sort of felt my way through the whole process with a lot of help from Johnthan. If I had to do the whole thing again I'd use sudo apt-get.. because Aptitude is so poor. I still have not made up my mind about qt-Creator and the whole development environment. I might stick with it or find something else.

nick

WarEnd 4 years, 3 months ago

Hi I tray to compile latest version for my raspberry pi, but i get error:

 

/home/pi/fritzing/fritzing/src/fapplication.cpp:-1: error: undefined reference to `qInitResources_phoenixresources()'

:-1: error: collect2: ld returned 1 exit status

WarEnd 4 years, 3 months ago

:) :) :) :)

Compiles and running very well on raspberry pi.

With QTcreator configure fritzing like in this  tutorial, then don’t build with QTcreator. Exit creator navigate to fritzing path and type: qmake, make, sudo make install.

snu 1 year, 10 months ago

Trying this nowadays, I can't compile it properly. I don't have the errors right in front of me, but I'm using the same version of QT and I have tried 0.9.0 and 0.9.2. I think the main error complains that QTSerialPort (or something similar) is referenced but not found. I'm a major newbie to C++.