This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Error message in razor-qt desktop

ralcocer 5 years, 2 months ago

I am using razor-qt as my desktop but I get the following message: Cannot mix incompatible Qt library (version 0x40804) with this library (version 0x40803)

/opt/fritzing-0.7.12b/Fritzing: line 16:  6094 Aborted                 "$dirname/lib/$appname" $*

razor uses Qt-4.8.4. It works OK in GTK .

Thanks

Jonathan Cohen 5 years, 2 months ago

Hi Ralcocer,

I am not sure this will work, but:

In the folder where Fritzing is installed, there is a subfolder called "lib" which contains copies of the Qt 4.8.3 libraries: a bunch of files of the form 'libQt...so.4'. You could try deleting those. Fritzing also relies on a couple of Qt Plugins which are in subfolders of the lib folder. I am not sure whether those will be compatible or not. If those plugins don't exist in your 4.8.4 installation and you delete the 4.8.3 versions, Fritzing will not work correctly.

Let us know what happens.

- j