This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

[0.8.b](mac) Compilation instruction error

laurentC 5 years ago

i followed the explanation and got a problem: the xcode project is not valid. I got an xcode error saying the project can't be parsed.

Command used to create the project: qmake -spec macx-xcode

Thanks

Jonathan Cohen 5 years ago

Hi Laurent,

We generally find it a lot easier to build Fritzing using QtCreator on Mac rather than to build it with xcode. In either case, if you are using a recent Mac OS, I would start by opening up the phoenix.pro project file in a text editor and removing the irrelevant CPUs from the following line:

        CONFIG += x86_64 x86 ppc

So probably yours will now read:

        CONFIG += x86_64

If that doesn't work and you still want to go with xcode, I have some vague memory that installing an older xcode might help--but it's been quite a while since the last time I tried this...

- j