This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Starterkit: Anschl├╝sse des Mega anders als die des Uno?

Harry778 6 years ago

Hallo zusammen,

gestern kam mein Fritzing Starterkit mit Arduino Mega.

Eben hab ich das Matrix-Beispiel (Handbuch S.50) nachgebaut. Leider leuchteten nicht alle LED, die hätten leuchten sollen. Also hab ich in der int image alle Zahlen auf 1 gesetzt, es hätten also alle LED leuchten müssen. Stattdesen sah das dann so aus:

{1,1,1,1,0,1,1,1}, 
{1,1,1,1,0,1,1,1},
{0,0,0,0,0,0,0,0},
{1,1,1,1,0,1,1,1},
{1,1,1,1,0,1,1,1},
{0,0,0,0,0,0,0,0},
{1,1,1,1,0,1,1,1},
{0,0,0,0,0,0,0,0}

Dann hab ich ein bissel rumprobiert. Wenn ich die Stecker, die laut Anleitung in die Pins A0 bis A3 gehören, in die Pins 14 bis 17 des Mega stecke leuchten plötzlich alle LED.

Ist also die Belegung bei Uno und Mega anders oder liegt bei mir irgendwo ein Fehler?

 

Vielen Dank und herzliche Grüße

Stephan Weber

 

Stefan Hermann 6 years ago

Stefan Hermann

Hi Stephan,

sehr gut recherchiert! Die Pins 14, 15, 16, 17, die vom Beispiel verwendet werden sind beim Arduino MEGA einzeln ausgeführt, beim Arduino UNO sind das die Analogen Input Pins 0, 1, 2, 3. Du hast es also genau richtig gemacht.

Die Kabel, die im Beispiel am Arduino bei Analog 0-3 anliegen, müssen im MEGA stattdessen in die Pins 14 – 17 gepatcht werden.

Liebe Grüße und Dank für den Hinweis,

Stefan"

Harry778 6 years ago

Hallo Stephan,

vielen Dank für Deine schnelle Antwort!

Gibt es noch mehrere solcher Unterschiede bezüglich der Beispiele aus dem Buch? Wenn ja, sind die irgendwo dokumentiert? Falls nicht bitte nachholen.

Für jemanden wie mich, der noch nicht verstanden hat, was er da eigentlich macht und erstmal brav die Beispiele zusammensteckt ist sowas sehr zeitaufwändig (ich hab mindestens dreimal den kompletten Aufbau Kabel für Kabel kontrolliert) - ich hab ja keine Ahnung, wo ich ansetzen könnte. "Todesmutig" hab ich die Kabel dann halt umgesteckt - immer mit dem Risiko, dass es "paff" macht und mir was durchschmort.

Danke Dir und Grüßle

STephan

 

 

Beatqueen 5 years ago

Hey ihr beiden,

 

Ich habe ein ähnliches Problem, auch das Arduino Mega und die LED Matrix. Allerdings wenn ich die Verkabelung aus dem Buch nehme leuchtet bei mir nur folgendes:

{0,1,0,0,0,1,0,1},  
{0,1,0,0,0,1,0,1},
{0,0,0,0,0,0,0,0},
{0,1,0,0,0,1,0,1},
{0,1,0,0,0,1,0,1},
{0,0,0,0,0,0,0,0},
{0,1,0,0,0,1,0,1},
{0,0,0,0,0,0,0,0}

 

stecke ich nun die Kabel um so wie ihr es hier beschreibt in die Pins "TX3-14", "RX3-15", "TX2-16", "RX2-17", leuchtet bei mir folgendes:

 

{0,1,0,0,1,1,0,1},  
{0,1,0,0,1,1,0,1},
{0,1,0,0,1,1,0,1},
{0,1,0,0,1,1,0,1},
{0,1,0,0,1,1,0,1},
{0,1,0,0,1,1,0,1},
{0,1,0,0,1,1,0,1},
{0,0,0,0,0,0,0,0}

 

Ich wäre über Hilfe sehr dankbar.
Grüße,

 

David

Beatqueen 5 years ago

Habs geschafft