This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

Version 0.4.0 Linux Crashing

m4rlin42 8 years, 7 months ago

<!-- @page { margin: 0.79in } P { margin-bottom: 0.08in } -->

Hello, just downloaded the 0.4.0 and was very excited to see the programming window and at least one new component I needed (4 leg RGB LED). First thing I tried to do was open a previously saved .fz and when it hits 70% it crashes, every time. It was built with 0.3.19 if that helps. It seems I am able to start a new project no problem, but I have only had it for about 10 mins.

I hope this is in some way helpful.

Ubuntu 10.04 (32bit)

Jonathan Cohen 8 years, 7 months ago

Hi M4rlin42,

Sorry for the crash.  Please email your sketch to info (at) fritzing (dot) org, and we'll try to figure out the problem.  If there are custom parts in the sketch, open it up in up again with 0.3.19, and save it as shareable, and email us the fzz file.

Thanks.

- j

m4rlin42 8 years, 7 months ago

Sent.

Jonathan Cohen 8 years, 7 months ago

Thanks.  The file loads fine under 0.4.0 windoze--I'll try it under linux when I get back to a linux machine in a few hours.  A few hours ago I ran the linux 32-bit version of Fritzing 0.4.0 on a 64-bit linux machine, and got a similar-seeming crash (death at 70%) when loading the stepper motor example file.  But there was no crash loading the same file when running the linux 64-bit version of Fritzing. 

Any chance this is what's happening in your case?

Thanks.

- j

Jonathan Cohen 8 years, 7 months ago

Today's theory is that it has something to do with jumperitems.  For now, if you remove the jumper items from the sketch you sent (with version 0.3.19), then it will load up in 0.4.0 without crashing.  You can then put the jumpers back in (manually or by autorouting) and continue working in 0.4.0.   

The investigation will continue...

- j

arcol 8 years, 7 months ago

I just run into it. For me (linux 32 bit version. Im on ubuntu 9.04) the following fritzing file crashes:

http://fritzing.org/projects/nixi-tube-control-driver-shield-for-arduino/

 

About the 70% while it loads.

Here is the gdb output.

(gdb) r
Starting program: /home/lama/Asztal/down/fritzing.2010.07.06.linux.i386/Fritzing
[Thread debugging using libthread_db enabled]
[New Thread 0xb5272710 (LWP 19881)]

** (<unknown>:19881): CRITICAL **: atk_object_set_name: assertion `name != NULL' failed
[New Thread 0xb4000b70 (LWP 19884)]
[Thread 0xb4000b70 (LWP 19884) exited]
[New Thread 0xb4000b70 (LWP 19885)]
QFont::setPixelSize: Pixel size <= 0 (0)
QFont::setPixelSize: Pixel size <= 0 (0)
QFont::setPixelSize: Pixel size <= 0 (0)
[New Thread 0xb3068b70 (LWP 19886)]
[New Thread 0xb26cbb70 (LWP 19887)]
[Thread 0xb26cbb70 (LWP 19887) exited]
[New Thread 0xb26cbb70 (LWP 19888)]
[Thread 0xb3068b70 (LWP 19886) exited]




QFont::setPixelSize: Pixel size <= 0 (0)
QFont::setPixelSize: Pixel size <= 0 (0)
QFont::setPixelSize: Pixel size <= 0 (0)

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb5272710 (LWP 19881)]
0xb5ef9c6f in ?? ()
   from /home/lama/Asztal/down/fritzing.2010.07.06.linux.i386/./lib/libQtGui.so.4
(gdb)

Would be nice if the debug symbols would be included in the binary. I would not mind the filesize. The program is still in beta stage afterall. (so useful bugreports needed;-)

 

Best regards,

 Laszlo

 

arcol 8 years, 7 months ago

0.3.19b version loads the above file just fine...

http://fritzing.org/download/0.3.19b/linux-32bit/fritzing.2010.04.16.linux.i386.tar.bz2

Jonathan Cohen 8 years, 7 months ago

By the way, this problem should be fixed in the newly released Fritzing 0.4.1.

- j

arcol 8 years, 7 months ago

> By the way, this problem should be fixed in the newly released

> Fritzing 0.4.1.

 

I downloaded it from here:

http://fritzing.org/download/0.4.1b/linux-32bit/fritzing.2010.07.17.linux.i386.tar.bz2

 

I tried to run it, but Im unable to do so.

./Fritzing.sh
/home/lamzor/Asztal/down/fritzing.2010.07.17.linux.i386/./Fritzing: /lib/tls/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by /home/lamzor/Asztal/down/fritzing.2010.07.17.linux.i386/./lib/libQtGui.so.4)

Version 2010.07.06 works fine. Im on ubuntu 9.04. My libc version is:

ii  libc6                                      2.10.1-0ubuntu15                         GNU C Library: Shared libraries

The problem with it, that libc is the crucial part of the system, so not easy to upgrade.

Was this version built on a different computer then the other previous ones?

Jonathan Cohen 8 years, 7 months ago

Yes, we're now building on ubuntu 10.04, using Qt 4.6.2.  

- j

 

 

tambalay 4 years, 5 months ago

thank you for the link