This forum is archived, go to the new forum!

This is the old fritzing discussion forum. Search it for valuable information from 2009 to 2015.

PCB view ratsnest connections not matching breadboard

mcschaefer 2 years, 9 months ago



I am a new user of Fritzing. I just created a breadboard layout of a circuit I am designing. After finishing it, I went to PCB layout to begin laying out my PCB and the very first trace I clicked on does not match the conncetions I made in my breadboard. It seems as though the pins of the 7 segment LED's are shifted over by one.


I noticed that the particular 7 segment LED part I was using actually had incorrect pin assignments in this exact way. So I deleted all of the instances of that 7 Segment LED on my breadboard and replaced them with a different 7 segment LED that has the correct pin assignments. The issue still persists and I am at a standstill until I figure out how to solve this. Any help would be greatly appreciated!


Operating System: Mac OSX Yosemite 10.10.2

Fritzing Version: 0.9.2


Zoomed in breadboardPCBFull Breadboard

mcschaefer 2 years, 9 months ago

Seems like my photos aren't posting. Here are Flickr links:

picnic 2 years, 7 months ago

I'm having similar sorts of issues. I have a pushbutton switch (where pins 1&2 are connected and 3&4 are connected) On the breadboard I've wired up pins 2 and 3 but the schematic shows that I'm using pins 1 and 2 - there are no pins 3 and 4 (schematic in fact shows 2 pin ones and 2 pin twos). Other wires I have from the microcontroller to a programming header connector are plain missing.



Using beta 0.9.2b if that makes a difference.